Please check if your operation system meets minimum requirements for the App to work on your smartphone.

For Android users you need (7.0 Nougat) or higher.

For iPhone users you need (iOS 13.4) or higher.

Did this answer your question?